Node.js Version Required for Next.js

Last updated on 26 Aug, 2022

Next.js is an isomorphic application framework created on top of React. It requires Node.js version 12.22.0 or higher to run Next.js.

For a safer side, I suggest you to check the required version directly on Next.js website. You can find it under System Requirements of Next.js.

If you are using an old version of Node.js, you can download the latest from the Node.js website.

At the time of writing, the required Node version for Next.js is v12.22.0 and latest Node.js LTS version is v16.17.0. So, in most of the case, the Node.js in your machine will meet the system requirements of Next.js.